PC CAPTURE VIA HDMI

Studio Operators

 

Hello, 

Im trying to capture as video input ( via blackmagic quad hdmi) a windows 10 laptop (I tried with many different models). However the input is always black. Works fine in other applications.

ps. camera input works fine.

Do you have some suggestions ?


Thanks

Francesco


   fr4nkx

 
Profile Image
ahmed ahmed
6/29/2020 12:03:51 PM
  -  

Maybe this topic can help you

https://my.aximmetry.com/post/331-can-not-get-camera-input-using-black-magi

 


 
Profile Image
fr4nkx
6/29/2020 2:38:57 PM
  -  

No, I've already seen it. Resolution and framerate is coherent with the blackmagic.


 
Profile Image
ahmed ahmed
6/30/2020 7:34:39 PM
  -  

If you dint solve your problem ,I suggest that you  take some screenshot of your aximmetry workflow(startup config,log window,flow screen..)  and send it to Aximmetry or upload it to this forum .

By doing that I think you will help them to figure what the problem is.

 
Profile Image
Aximmetry
7/8/2020 3:34:30 PM
  -  

Hi Francesco,

- Firstly, how did you insert a Quad HDMI card into your laptop?  Do you use some interface?

- "Resolution and framerate is coherent with the blackmagic"   I'm not sure if this is a typo, but they have to be coherent with the camera's current settings.

 
Profile Image
fr4nkx
9/9/2020 10:34:29 AM
  -  

Hi Axymmetry,

- The Quad HDMI is in the desktop that is running Axymmetry.

- Video Cameras are working fine, not a single problem.

- The problem is with PCs signals. I can see them in the blackmagic capture software (Blackmagic express) but I have a black screen in the source monitor in axymmetry. I've tried many resolution and refresh rates but nothing.


I was thinking that maybe, since the QuadHDMI is listed among the supported devices, you have some suggestions or tricks to make it work with pc signals in axymmetry.


Thanks

Francesco






 
Profile Image
emre_serim
9/9/2020 8:40:04 PM
  -  

hi,

we also have this problem with nvidia desktop windows computer. properties of the screen shown in blackmagic software as we set up but in Aximmetry, it's black screen.

 
Profile Image
fr4nkx
9/10/2020 5:06:46 PM
  -  

hi, yes I think the nvidia might be involved.


@Aximmetry I've notice something that can help.

In OBS Studio I have to set the pixel format to BRGA in order to view the captured pcs via the blackmagic. I've looked into Aximmetry but I didnt find any setting like that... Can you help ?


Thanks

Francesco

 
Profile Image
fr4nkx
9/15/2020 3:30:10 PM
  -  

Fun fact: it works if you set the laptop second screen to 4k or 2160p resolution :D

1080p and 1920x1200 still black screen.


 
Profile Image
Aximmetry
9/21/2020 8:51:58 AM
  -  

Hi all,
Thank you for all the info, we'll investigate the problem and release a fix.