Suggestions For solving audio clicking and drop when Pc have High Load

FAQ Composer Video Playback SDI

 

Are there any suggestions about improve audio/video playback?
I have a lot of audio distortion and very bad media file playback also when using SDI input

The PC Configuration

I7 cpu

240 SSD

NVIDIA GeForce GTX 1660

and DeckLink 4K Extreme 12G

   ahmed ahmed

 
Profile Image
Aximmetry
7/16/2019 7:57:35 AM
  -  

When the GPU or CPU load is very high (red strip on the indicator panel), you cannot avoid drops and clicks.

I'm not sure what is the bottleneck in your case. You can try with a stronger graphics card.

 
Profile Image
ahmed ahmed
7/16/2019 9:40:46 AM
  -  

Are there any tools or methods in aximmetry to identify the cause of bottleneck of gpu/CPU?

 
Profile Image
Aximmetry
7/16/2019 1:10:29 PM
  -  

Just watch the indicators on the Processor Load panel if any of them are red.

What framerate do you use? And which scene do you experience this problem with?

 
Profile Image
ahmed ahmed
7/16/2019 1:35:00 PM
  -  

I Am using 1080/i50 with sport virtual set with 2 full hd 1080/50i as input for virtual screen and actor

 
Profile Image
Aximmetry
7/16/2019 1:51:02 PM
  -  

In this case the system runs at 50 fps. Also the data uploading of the inputs takes some time from the GPU.

It means that your GTX 1660 probably can be a bottleneck. We usually recommend at least a GTX 1080 for this type of usage.

Regarding the CPU:  which model of i7 do you use?

 
Profile Image
ahmed ahmed
7/16/2019 8:36:55 PM
  -  

are there any suggestions for media file codecs?

Also Are there any options to increase the priority of processing videos and audio over other things?

maybe an option to cache some of elements on disk.

finally i wish of there any performance monitoring tool for example like this one

https://docs.derivative.ca/Performance_Monitor

 
Profile Image
Aximmetry
7/16/2019 9:06:21 PM
  -  

The problem is not the video/audio processing, but that the system cannot finish the render of a frame in time.

If you have a good CPU video decoding is not a problem.  But if there is a frame drop because of the rendering overload the audio output will stutter as well.

 
Profile Image
ahmed ahmed
7/17/2019 4:49:37 PM
  -  

I think that newer versions of aximmetry 2019.3 software have some performance problems comparing to 2019.2 one

 
Profile Image
Aximmetry
7/17/2019 8:50:02 PM
  -  

Could you give me a specific example?

 
Profile Image
ahmed ahmed
7/18/2019 5:51:42 AM
  -  

I think that studio library example files like news studio have better performance in 2019.2.x than 2019.3.x one

 
Profile Image
Aximmetry
7/18/2019 4:21:11 PM
  -  

There was a change in that scene, indeed.
The same mirror image was used for both ground levels in the scene which is incorrect, and we've fixed it.

Upon this we did not experience any performance drop on our hardwares, but it's possible that it affects your one.

Could you try the following:

Enter NewsRoom-Studio-Preset-Mode 1  with an Alt + double-click.

Enter Studio with a double-click.

Find the to MIRROR modules.

Select MIRROR-2 and change the From Tunnel property to MIRROR-1.

     


Could you report back to us if this restore the previous performance?
Thanks.

 
Profile Image
ahmed ahmed
7/18/2019 7:50:49 PM
  -  

i think that i was old version  of the  project with aximmetry 2019.3.x after updating the project to current version i have better performance of old one with default configuration

 
Profile Image
Aximmetry
7/19/2019 11:14:50 AM
  -  

Sorry, can you clarify this a bit more.

A)  you tried with the same software version,  but different versions of Projects

or

B) you tried with the same Projects,  but different versions of software ?

 
Profile Image
ahmed ahmed
7/19/2019 1:47:24 PM
  -  

Sorry I meant same software version,  but different versions of Projects

 
Profile Image
Aximmetry
7/19/2019 4:38:03 PM
  -  

Ok, thanks.  In this case my previous answer is valid.  Please try what I suggested.