I have just installed the SE community version and I get the following error when launching

Installation Bugs Installer

 

I have installed the SE community version and when launching I get the following error

"win32 handle that was passed to Icon is not valid"

what can I do to resolve that?

I have tried uninstalling and reinstalling.


Nothing helps OS Build 19041.388

PS : From searching the internet this is probably related to trying to load some Icons from the Shell32.dll that are not there. Lets see if I get any answer on that. :(

   buffos

 
Profile Image
buffos
8/1/2020 12:05:29 AM
  -  

Here is my log file


[03:00:50] [UI] Loading plugin Aximmetry.Plugins.Standard3D.dll

[03:00:50] [UI] Loading plugin Aximmetry.Skins.dll

[03:00:50] [Main] Loading library AximmetryEngine.Plugins.DMX.dll

[03:00:50] [Main] Loading library AximmetryEngine.Plugins.Mapping.dll

[03:00:50] [Main] Loading library AximmetryEngine.Plugins.ModularShaders.dll

[03:00:50] [Main] Loading library AximmetryEngine.Plugins.NVGameWorks.dll

[03:00:50] [Main] Loading library AximmetryEngine.Plugins.Standard.dll

[03:00:50] [Main] Loading library AximmetryEngine.Plugins.Standard3D.dll

[03:00:50] [Main] Adding device type Video: DirectShow

[03:00:50] [Main] Adding device type Audio: DirectSound

[03:00:50] [Main] Adding device type AudioChannel: DirectSound

[03:00:50] [Main] Adding device type AudioOut: DirectSound

[03:00:50] [Main] Adding device type MIDI: 

[03:00:50] [Main] Adding device type MIDIOut: 

[03:00:50] [Main] Adding device type GPIO: Serial

[03:00:50] [Main] Adding device type Keyboard: 

[03:00:50] [Main] Adding device type Game: DirectInput

[03:00:50] [Main] Adding device type Game: OpenVR

[03:00:50] [Main]     **** Installation path could not be located (110)

[03:00:50] [Main]     **** Failed

[03:00:50] [Main] Adding device type Game: Antilatency

[03:00:50] [Main]     **** Antilatency environment not found

[03:00:50] [Main]     **** Failed

[03:00:50] [Main] Adding device type CameraTracking: Game

[03:00:50] [Main] Pre-registering plugin AximmetryEngine.Plugins.DMX.dll

[03:00:50] [Main]     Adding device type DMX: ArtNet

[03:00:50] [Main]     Adding device type DMXOut: ArtNet

[03:00:50] [Main]     Adding device type DMXOut: Eurolite

[03:00:50] [Main]     Adding device type DMXOut: Stage Line DMX-510

[03:00:50] [Main]         Loading library DMX510.DLL

[03:00:50] [Main]             **** Failed

[03:00:50] [Main]         **** Failed

[03:00:50] [Main] Pre-registering plugin AximmetryEngine.Plugins.Standard.dll

[03:00:50] [Main]     Adding device type Video: Blackmagic

[03:00:50] [Main]     Adding device type VideoOut: Blackmagic

[03:00:50] [Main]     Adding device type Video: Magewell

[03:00:50] [Main]     Adding device type VideoOut: RTMP

[03:00:50] [Main]     Adding device type VideoOut: YouTube

[03:00:50] [Main]     Adding device type VideoOut: Facebook

[03:00:50] [Main]     Adding device type VideoOut: Twitch

[03:00:50] [Main]     Adding device type VideoOut: Restream.io



 
Profile Image
Aximmetry
8/5/2020 2:28:27 PM
  -  

Hello Buffos,

have you tried installing Aximmetry on another PC or under another windows system? If you have, have you experienced the same issue?

 
Profile Image
buffos
8/5/2020 2:40:38 PM
  -  

No I did not try, for 3 reasons

1. I do not want to mess up with the licensing system
2. What if that happens in my pc that is used for production. There would be no alternative.
3. Even if it works on another pc, that will not solve the problem and I cannot work on that pc and evaluate before buying

The error, as far as I can remember from my dev days, is simply because the programmers expect some icon to be there in the shell32.dll that simply is not

If indeed you are reading icons from the shell32.dll, then the bug is there.

I am using the latest windows version (insiders). 19041.423

 
Profile Image
buffos
8/5/2020 4:38:53 PM
  -  

If you need any dll file from my system I can email it to you.

 
Profile Image
buffos
8/6/2020 7:48:40 AM
  -  

Ok. To prove my point, I installed it on another pc. Exactly the same error. And that PC has barely anything installed on it.

Here is a screenshot of the error

The error is trying to get an icon that does not exist.

Try it on a clean installation without pre-existing Aximmetry install and if you want I can email you any required dll files.


 
Profile Image
buffos
8/8/2020 2:33:44 PM
  -  

Did anyone from the community make a clean install recently?
To a system that previously never had Aximmetry.

The main answer is they had no complaints, but the question is how many clean installs did they have

Until I get an answer maybe I can find out why this happens (in 2 clean installs)


 
Profile Image
TwentyStudios
8/8/2020 4:49:06 PM
  -  

There are probably quite a few new installation, but I doubt many are using the bleeding edge Windows Insider update. It’s usually good practice to wait a while for bugs to settle and developers to update their software before updating to a new Windows feature update or even beta OS release. If it mostly works well for everyone else, a good place to start is to look at what is different with your setup. I bet that your version of Windows is it.

I’ll be installing Aximmetry on a completely new machine early next week. Unfortunately it came updated to the latest Windows version, so,it will be a perfect test to see if it works for me. I’ll report back here.

 
Profile Image
buffos
8/8/2020 4:56:49 PM
  -  

Thank you.