NDI Out to Vmix - Freezing

Bugs Video Playback NDI

 

I'm using the aximmetry NDI output and capturing in vmix. Approximately every 30 seconds the Aximmetry FPS monitor indicates a drop from 29 to 27fps... and at this moment the video gives a momentary freeze in the vmix.

In the aximmetry preview nothing happens, the image flows without problems, but in the ndi output this crash occurs.

I tried to use the buffer increase feature in vmix but the problem is still noticeable.

Through the SDI output also nothing happens, the problem is only focused on the NDI output and it only occurs when Aximmetry signals this FPS drop by changing the bar to red color.

   adolfo

 
Profile Image
Ahmed@Aximmetry
6/25/2022 2:02:03 PM
  -  

Hello,

Does all of your video settings from input to output? You need to have everything set up to 30 FPS if that is your intended final output. 

Does this issue show up from the beginning or after a while of running the scene? Can you check your GPU and CPU temperatures under load using CPU-Z, GPU-Z, and the task manager? Try to follow the usage and temperature levels of your CPU and GPU at the start and during the running of the scene. 

Best regards,



 
Profile Image
adolfo
6/26/2022 5:23:01 PM
  -  

Ahmed, thanks for your feedback.

GPU and CPU temperature remain stable. The machine has a good cooling system and is well dimensioned for the activity. It's definitely not overloading.

I ran some more tests and the problem starts around 4 minutes after the scenario starts. As I said, what strikes me the most is the fact that when the FPS drops, only the NDI output is affected.

This is a very fast drop, less than 1 second and it stabilizes. But enough to be well perceived in the video.

I send a photo taken at the time of the drop in FPS, note that nothing is overloaded.

 
Profile Image
Ahmed@Aximmetry
7/1/2022 9:35:42 AM
  -  

Hello,

Thank you for your input. Some of the video loading and processing tasks are not represented on the CPU meter. 

Are you using any video player? If yes,  the buffered option of the Video Player module may help.


Can you let us know what exactly happens in your scene after 4 mins? Any specific video starts to play? or a certain animation? The more details you give us the easier we can locate the issue.

Best regards,